Emails are delayed
Incident Report for atSpoke
Resolved
Our Email Service Provider has deployed a fix, and emails should no longer be delayed. We will continue to monitor their status.
Posted Nov 27, 2019 - 04:49 UTC
Update
Posted Nov 26, 2019 - 22:10 UTC
Identified
Our Email Service Provider is having a service-wide issue which is causing delays in emails being posted to Spoke. We have identified the issue and are working with them to find a quick resolution.
Posted Nov 26, 2019 - 22:09 UTC
This incident affected: Email.