Delays in sending emails
Incident Report for Spoke
Resolved
All systems are fully operational.
Posted Mar 09, 2018 - 21:39 UTC
Monitoring
Our Email provider was experiencing delays in sending emails. This appears to have been fixed, and we are closely monitoring the situation.
Posted Mar 09, 2018 - 18:31 UTC